HDU - 6225

Problem Description

Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.

Input

The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.

Output

For each test case, output a line with the total number of boxes.

Sample Input

4
1 2 3 4
0 0 0 0
1 0 0 0
111 222 333 404

Sample Output

10
0
1
1070

题目分析

思路

本题应该是一个大数运算,所以,我选择使用Java来着手,因为Java自带了BigInteger类。(个人认为语言不应该成为一个程序员的限制,用合适的语言做合适的事情)。

AC代码

import java.io.*;
import java.math.*;
import java.util.*;

class Main {
    public static Scanner s = new Scanner(System.in);
    public static void main(String[] args) {
        int t;
        t = s.nextInt();
        while (t-- != 0) {
            BigInteger temp;
            BigInteger sum = new BigInteger("0");
            for (int i = 0; i < 4; i++) {
                temp = s.nextBigInteger();
                sum = sum.add(temp);
            }
            System.out.println(sum);
        }
        
    }
}
Last modification:July 17th, 2019 at 10:10 am
如果我的文章对你有用,请随意赞赏,不要白嫖哦~